[RAID101.com] Easy Table BBCode 1.0

Discussion in 'PC Hardware and Software' started by MOZ, Aug 12, 2012.

Share This Page

  1. bubbl3

    bubbl3 RAID Rookie

    Messages:
    6
    Likes Received:
    3
    Reputation:
    0
    I get this error when i try to post a table bbcode:
    Code:
    Parse error: syntax error, unexpected T_STRING in /var/www/clients/client1/web1/web/library/EasyTableBBCode/BBCode/Formatter/Base.php on line 1
    It also pulls out a javascript error when i try to preview it.
    This is the code i used:
    Code:
    [/COLOR][/FONT][/SIZE][FONT=Tahoma][COLOR=#bcbcbc][table][/COLOR][/FONT][FONT=Tahoma][COLOR=#bcbcbc] [/COLOR][/FONT][B]BBB[/B][FONT=Tahoma][COLOR=#bcbcbc] [/COLOR][/FONT][FONT=Tahoma][COLOR=#bcbcbc]|[/COLOR][/FONT][B] Bottoms[/B][FONT=Tahoma][COLOR=#bcbcbc] [/COLOR][/FONT][FONT=Tahoma][COLOR=#bcbcbc]|[/COLOR][/FONT][FONT=Tahoma][COLOR=#bcbcbc] [/COLOR][/FONT][B]More BBB[/B][/COLOR][/FONT][/SIZE]
    [COLOR=#000000][SIZE=4][FONT=Times New Roman][FONT=Tahoma][COLOR=#bcbcbc]\ [COLOR=#00ff00]Good[/COLOR] | [COLOR=#ff6600]Fine[/COLOR] | [COLOR=#800000]Better[/COLOR][/COLOR][/FONT][/FONT][/SIZE][/COLOR]
    [COLOR=#000000][SIZE=4][FONT=Times New Roman][FONT=Tahoma][COLOR=#bcbcbc]\ Yay | Vroob | Wooot[/COLOR][/FONT][/FONT][/SIZE][/COLOR]
    [COLOR=#000000][SIZE=4][FONT=Times New Roman][FONT=Tahoma][COLOR=#bcbcbc]\ Got it[/COLOR][/FONT][/FONT][/SIZE][/COLOR]
    [COLOR=#000000][SIZE=4][FONT=Times New Roman][FONT=Tahoma][COLOR=#bcbcbc] [/COLOR][/FONT][/FONT][/SIZE][/COLOR]
    [COLOR=#000000][SIZE=4][FONT=Times New Roman][COLOR=#000000][SIZE=4][FONT=Times New Roman][FONT=Tahoma][COLOR=#bcbcbc]| OK[/table][/COLOR][/FONT]
     
  2. MOZ

    MOZ RAID Leader Staff Member

    Messages:
    2,362
    Likes Received:
    1,064
    Reputation:
    4,403
    Checking it right now.
     
    bubbl3 likes this.
  3. MOZ

    MOZ RAID Leader Staff Member

    Messages:
    2,362
    Likes Received:
    1,064
    Reputation:
    4,403
    Looks like you have way too many BBCodes in there.

    Here is what I used after some cleaning:
    Code:
    [table][B]BBB[/B][FONT=Tahoma][COLOR=#bcbcbc]|[/COLOR][/FONT][B] Bottoms[/B][FONT=Tahoma][COLOR=#bcbcbc]|[/COLOR][/FONT][B]More BBB[/B]
    [COLOR=#000000][SIZE=4][FONT=Times New Roman][FONT=Tahoma][COLOR=#bcbcbc]\ [COLOR=#00ff00]Good[/COLOR] | [COLOR=#ff6600]Fine[/COLOR] | [COLOR=#800000]Better[/COLOR][/COLOR][/FONT][/FONT][/SIZE][/COLOR]
    [COLOR=#000000][SIZE=4][FONT=Times New Roman][FONT=Tahoma][COLOR=#bcbcbc]\ Yay | Vroob | Wooot[/COLOR][/FONT][/FONT][/SIZE][/COLOR]
    [COLOR=#000000][SIZE=4][FONT=Times New Roman][FONT=Tahoma][COLOR=#bcbcbc]\ Got it[/COLOR][/FONT][/FONT][/SIZE][/COLOR]
     
    | OK[/table]
    
    --- Double Post Merged, Sep 6, 2012 ---
    Note that the formatting for each cell has to be done individually.
     
  4. bubbl3

    bubbl3 RAID Rookie

    Messages:
    6
    Likes Received:
    3
    Reputation:
    0
    Problem is, i'm getting it just enabling the addon and trying to post :(

    After posting anything i get:
    Code:
    Parse error: syntax error, unexpected T_STRING in /var/www/clients/client1/web1/web/library/EasyTableBBCode/BBCode/Formatter/Base.php on line 1
    Basically if i enable the addon, any page with bbcode gives that.
     
  5. bubbl3

    bubbl3 RAID Rookie

    Messages:
    6
    Likes Received:
    3
    Reputation:
    0
  6. MOZ

    MOZ RAID Leader Staff Member

    Messages:
    2,362
    Likes Received:
    1,064
    Reputation:
    4,403
    Interesting. Are you on PHP 5.4?
     
  7. bubbl3

    bubbl3 RAID Rookie

    Messages:
    6
    Likes Received:
    3
    Reputation:
    0
    Code:
    root@new:~# php -v
    PHP 5.3.10-1ubuntu3.2 with Suhosin-Patch (cli) (built: Jun 13 2012 17:19:53
    Copyright (c) 1997-2012 The PHP Group
    Zend Engine v2.3.0, Copyright (c) 1998-2012 Zend Technologies
    with XCache v1.3.2, Copyright (c) 2005-2011, by mOo
     
  8. MOZ

    MOZ RAID Leader Staff Member

    Messages:
    2,362
    Likes Received:
    1,064
    Reputation:
    4,403
    Definitely not. I'll have to troubleshoot more.
     
  9. MOZ

    MOZ RAID Leader Staff Member

    Messages:
    2,362
    Likes Received:
    1,064
    Reputation:
    4,403
    Updated to 1.0.1
     
    Latest Given Reputation Points:
    JD666: 25 Points (you rock!) Jan 11, 2013
    JD666 likes this.
  10. kazirhut

    kazirhut RAID Rookie

    Messages:
    11
    Likes Received:
    4
    Reputation:
    0
    awesome mod. thnx.
     
  11. vamped

    vamped RAID Rookie

    Messages:
    1
    Likes Received:
    0
    Reputation:
    0
    MOZ, love the table addon - I have been looking for a good table for my xencarta, but for some reason, it doesn't work with xencarta. However, it does work on regular posts.

    Any ideas?

    table.JPG



    table2.JPG
     
  12. dbg

    dbg RAID Staff Staff Member

    Messages:
    3,111
    Likes Received:
    1,144
    Reputation:
    2,952

    Hi vamped .. Thanks for your query.
    MOZ has some real world engagements .. He should respond once he's free.

    Anything we can help out with, please let us know.

    Cheers.
     
  13. vadsamoht

    vadsamoht RAID Rookie

    Messages:
    1
    Likes Received:
    0
    Reputation:
    0
    Hey, I'd just like to make a quick feature request. Would it be possible to be able to add an escape sequence for the | and \ characters? Currently there's no way of making those appear as text inside of the tables. Thanks.
     
  14. Frosto

    Frosto RAID Rookie

    Messages:
    1
    Likes Received:
    0
    Reputation:
    0
    Thank you very much. It works really well!
     
  15. MOZ

    MOZ RAID Leader Staff Member

    Messages:
    2,362
    Likes Received:
    1,064
    Reputation:
    4,403
    Happy to know that people are still using this, despite some recent errors and my lack of continued development.
     
    initpidzero likes this.
  16. Arkroyal

    Arkroyal RAID Rookie

    Messages:
    1
    Likes Received:
    0
    Reputation:
    0
    Doesn't work for me.
    I get the same error as reported earlier.

    Parse error: syntax error, unexpected T_STRING in /var/sites/t/theukbettingforum.co.uk/public_html/xenforo/library/EasyTableBBCode/BBCode/Formatter/Base.php on line 1
     
  17. MOZ

    MOZ RAID Leader Staff Member

    Messages:
    2,362
    Likes Received:
    1,064
    Reputation:
    4,403
    Support for this product has terminated.
     
  18. JD666

    JD666 RAID Leader Staff Member

    Messages:
    6,584
    Likes Received:
    1,801
    Reputation:
    5,403
    Huh, why? when? how?
     
  19. MOZ

    MOZ RAID Leader Staff Member

    Messages:
    2,362
    Likes Received:
    1,064
    Reputation:
    4,403
    Lack of time. And I will try to mod the redactor table plugin for XenForo. Just not right now.
     
    JD666 likes this.
  20. twhiting9275

    twhiting9275 RAID Rookie

    Messages:
    2
    Likes Received:
    0
    Reputation:
    0
    a bit late to the thread here, but this is spitting out a rather interesting error (rather pages of them per thread now)
    Code:
    ErrorException: Undefined offset: 6 - library/EasyTableBBCode/BBCode/Formatter/Base.php:57
    Generated By: Unknown Account, 1 minute ago
    Stack Trace
    #0 /home/usr/public_html/library/EasyTableBBCode/BBCode/Formatter/Base.php(57): XenForo_Application::handlePhpError(8, 'Undefined offse...', '/home/usr/p...', 57, Array)
    #1 [internal function]: EasyTableBBCode_BBCode_Formatter_Base->renderTagTable(Array, Array, Object(EasyTableBBCode_BBCode_Formatter_Base))
    #2 /home/usr/public_html/library/XenForo/BbCode/Formatter/Base.php(646): call_user_func(Array, Array, Array, Object(EasyTableBBCode_BBCode_Formatter_Base))
    #3 /home/usr/public_html/library/XenForo/BbCode/Formatter/Base.php(557): XenForo_BbCode_Formatter_Base->renderValidTag(Array, Array, Array)
    #4 /home/usr/public_html/library/XenForo/BbCode/Formatter/Base.php(481): XenForo_BbCode_Formatter_Base->renderTag(Array, Array, 0)
    #5 /home/usr/public_html/library/XenForo/BbCode/Formatter/Base.php(462): XenForo_BbCode_Formatter_Base->renderTreeElement(Array, Array, 0)
    #6 /home/usr/public_html/library/XenForo/BbCode/Formatter/Base.php(442): XenForo_BbCode_Formatter_Base->renderSubTree(Array, Array)
    #7 /home/usr/public_html/library/XenForo/BbCode/Parser.php(505): XenForo_BbCode_Formatter_Base->renderTree(Array, Array)
    #8 /home/usr/public_html/library/XenForo/BbCode/TextWrapper.php(117): XenForo_BbCode_Parser->render('The numbers fro...', Array)
    #9 [internal function]: XenForo_BbCode_TextWrapper->__toString()
    #10 /home/usr/public_html/library/MeCommand/ViewPublic/Thread/View.php(15): preg_replace('#(>|^|\r|\n)/me...', '\1<span class="...', Object(XenForo_BbCode_TextWrapper))
    #11 /home/usr/public_html/library/XenForo/ViewRenderer/Abstract.php(227): MeCommand_ViewPublic_Thread_View->renderHtml()
    #12 /home/usr/public_html/library/XenForo/ViewRenderer/HtmlPublic.php(67): XenForo_ViewRenderer_Abstract->renderViewObject('XenForo_ViewPub...', 'Html', Array, 'thread_view')
    #13 /home/usr/public_html/library/XenForo/FrontController.php(572): XenForo_ViewRenderer_HtmlPublic->renderView('XenForo_ViewPub...', Array, 'thread_view', NULL)
    #14 /home/usr/public_html/library/XenForo/FrontController.php(158): XenForo_FrontController->renderView(Object(XenForo_ControllerResponse_View), Object(XenForo_ViewRenderer_HtmlPublic), Array)
    #15 /home/usr/public_html/index.php(13): XenForo_FrontController->run()
    #16 {main}
    Request State
    array(3) {
    ["url"] => string(78) "http://www.domain.com/threads/ratings-monday-night-september-23-2013.16/"
    ["_GET"] => array(0) {
    }
    ["_POST"] => array(0) {
    }
    }
    Hopefully someone can help me figure out where this is causing this, even though support has been terminated for this. It's kind of important that I get table bbcode working
     

Share This Page